ODR: On-Demand Routing

Consider a little complicated network as shown in the following topology:

post_1

After setting basic configuration of layer-2 & layer-3 aspects, it is quite normal that each router successfully ping only directly-connected networks & all loopbacks are unreachable. Simply, because neither static nor dynamic routing are configured.

But, our aim by writing this post, is to inform you that after adding « only one » global configuration command: « router odr » on only the hub router « R1 ». In few seconds, we obtained full network connectivity !!!

This is the famous On-Demand Routing (ODR), which was added as an enhancement to Cisco Discovery Protocol (CDP), in order to propagate IP prefixes (mainly connected networks of stub routers) via CDP.

After enabling ODR on the hub, all stub network’ routes will be installed in the hub routing table. In addition, the hub router provides default route to all stub routers.

Hub configurationStub configurationHub showStub show
!
hostname R1
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
cdp run
!
interface Serial0/0
no ip address
encapsulation frame-relay
cdp enable
!
interface Serial0/0.1 point-to-point
ip address 10.1.2.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial0/0.2 point-to-point
ip address 10.1.3.1 255.255.255.0
frame-relay interface-dlci 103
!
interface Serial0/0.3 point-to-point
ip address 10.1.4.1 255.255.255.0
frame-relay interface-dlci 104
!
!
router odr
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
cdp run
!
interface Serial0/0
ip address 10.1.4.2 255.255.255.0
encapsulation frame-relay
cdp enable
!

!
R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
o 2.2.2.2 [160/1] via 10.1.1.2, 00:00:14, Serial0/0.1
3.0.0.0/32 is subnetted, 1 subnets
o 3.3.3.3 [160/1] via 10.1.3.2, 00:00:12, Serial0/0.2
4.0.0.0/32 is subnetted, 1 subnets
o 4.4.4.4 [160/1] via 10.1.4.2, 00:00:01, Serial0/0.3
10.0.0.0/24 is subnetted, 3 subnets
C 10.1.3.0 is directly connected, Serial0/0.2
C 10.1.1.0 is directly connected, Serial0/0.1
C 10.1.4.0 is directly connected, Serial0/0.3
!

!
R4# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.4.1 to network 0.0.0.0

4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.4.0 is directly connected, Serial0/0
o* 0.0.0.0/0 [160/1] via 10.1.4.1, 00:00:52, Serial0/0
!

Finally, it is important to note that:

  • Be careful that you do not forget CDP enabled.
  • ODR works properly on either broadcast or non-broadcast networks.
  • ODR is not CPU intensive and it consumes very little bandwidth.
  • ODR it is able to carry VLSM information.
  • ODR supports several settings.

For more information

http://www.cisco.com/c/en/us/support/docs/ip/on-demand-routing-odr/13710-39.html


Sorry Comments are Disabled